Windows 7 で PowerShell 3.0 を動かす

2016年1月18日

Windows 7 や Windows 2008R2 からはデフォルトで PowerShell がインストールされていますが、それは Version が 2 です。

お客様先で動かすのとか考えると Version 2 で作っていた方が楽かも知れませんが、PowerShell Version 2 は .NetFramework のVersion も 2.0 が要件なため微妙なことと、PowerShell ISE のバージョンが古くて使いにくい、また REST を直で叩けないという残念な感じなことに、使い始めて気づいてしまいました。

作業でサーッと作りたい時に使うのも PowerShell なので、次のサイトを参考に PowerShell は Version 3 に上げました。

確か要件はこんな感じだったはず

  • Windows 7 SP1 以上であること
  • .NetFramework 4.0 以上が入っていること
  • PowerShell ISE が入っていること